Loading...
X

VirtualBox Error “NS_ERROR_FAILURE (0x80004005)” (SOLVED)

After updating VirtualBox, all virtual machines stopped working, regardless of the guest operating system and their settings.

The situation is complicated by the fact that instead of an exact indication of the problem, when trying to start the virtual machine, only a general message is displayed that the session was terminated, as well as an error number, which is common to a number of errors related to the inability to start the virtual machine session.

Full text of the error:

The VM session was aborted.

Result Code: 
NS_ERROR_FAILURE (0x80004005)
Component: 
SessionMachine
Interface: 
ISession {c0447716-ff5a-4795-b57a-ecd5fffa18a4}

One possible reason is a mismatch between the versions of the VirtualBox Extension Pack and the installed version of VirtualBox.

VirtualBox Extension Pack is an extension that adds features such as support for USB 2.0 and USB 3.0 devices, VirtualBox RDP, disk encryption, NVMe and PXE boot for Intel cards.

To make sure that the reason is in the VirtualBox Extension Pack, you can disable the functions that the extension pack provides in the virtual machine settings (for example, rollback to USB 1.1 version) – after that the virtual machine should work without errors. Or go straight to updating the extension pack, which will solve the indicated problem.

To fix this problem, just install the version of the VirtualBox Extension Pack that matches the version of your VirtualBox.

If you installed the extension pack manually, then go to the VirtualBox download page https://www.virtualbox.org/wiki/Downloads and find the VirtualBox Oracle VM VirtualBox Extension Pack there.

Download and run the file by double clicking.

During the installation of the new version, you will be prompted to uninstall the old version.

The Linux repositories also contain the VirtualBox Extension Pack.

On Debian and derivative distributions (Linux Mint, Ubuntu, Kali Linux and others), to install the VirtualBox Extension Pack from the repository, run:

sudo apt install virtualbox-ext-pack

On Arch Linux and derivative distributions (Manjaro, BlackArch and others), to install the VirtualBox Extension Pack from the repository, run:

pikaur -S virtualbox-ext-oracle

If you get a message that the pikaur command was not found, then see the article “Automatic installation and update of AUR packages”.

If you receive an error that the VirtualBox Extension Pack is already installed, for example:

VBoxManage: error: Extension pack 'Oracle VM VirtualBox Extension Pack' is already installed. In case of a reinstallation, please uninstall it first

Then you need to start by removing it manually. To do this, open VirtualBox, go to the menu File → Preferences → Extensions.

Uninstall VirtualBox Extension Pack.

After that, restart the installation of the VirtualBox Extension Pack from the repository.

After updating the VirtualBox Extension Pack, the “NS_ERROR_FAILURE (0x80004005)” error is gone.


Leave Your Observation

Your email address will not be published.